Page 1 of 1

Wayway Q4033 GPS

Posted: Wed Sep 21, 2016 8:47 am
by bukitimah
Hi, I must be 1 of the few that still holding to his GPS. It has served me well and I also managed to download latest maps here.

Once a while, I do find difficulties to activate the touch screen because the calibration is out. All I need to do is to go to setting and re-calibrate and it works for a long time. However, recently the calibration is out again. Since the last icon is Games, I cannot go to the setting icon because each time I try to search for the next icon, it activates the games icon. There is also no way to reset the system. Can anyone help to see if I can still recover this GPS?

I also tried to reset by pressing the back reset button. Nothing happen.

Thank you in advance.

Re: Wayway Q4033 GPS

Posted: Sat Mar 25, 2017 2:32 pm
I have the same problem with WAYWAY

I tried several times to email contact their support and end up in Malaysia with no response other than please
come into our walk in store in malaysia

I was only asking for a user manual or any manual they can upload

Now today the WAYWAY is stuck with a Chinese language and there are no instructions to set language or return
the unit into calibration

I notice the on the top there is a grey out icon looks like a water faucet icon between the battery icon and the radio with a small antenna icon
All icons work around the grey + shape water faucet icon but pushing this grey icon does nothing

It may be the WAYWAY is locked out by a password or the internal battery may be reset if it can be removed and opened by the four small back
screws... WAYWAY and theu M3 support refuse to answer any support help so it may be a solution to open the unit and reset the Microsoft
Windows Operating Embedded software from inside the cover...

Any body has done this been inside the cover? It is worthless junk and has zero support manufactured in China

Re: Wayway Q4033 GPS

Posted: Thu Aug 16, 2018 10:57 am
by j3home
This response may come a little bit late, but better late then never.
I recently encountered the same calibration problem with my Wayway Q4033 after not using it for quite a long time. Couldn't use the "Settings" function to do the touch-screen re-calibration as the it always activate the "Games" function instead. The problem was resolved after I open up the unit and then the screen itself. As the the edge of the screen is usually covered up by the plastic cover, removing the cover and the screen itself allows me to access the outer edge of the screen where I can still access the "Settings" function. From there I can then select the Re-calibration function to re-calibrate the touch-screen before I assemble it back again.