Singapore - Feedback (Q4 2009)

Moderators: Chuah, Moderators, Regional Mappers

User avatar
OngCC
Senior Mapper
Posts: 1434
Joined: Sun Sep 14, 2008 12:44 pm
Location: Redhill, SG
Contact:

Re: Singapore - Feedback (Q4 2009)

Postby OngCC » Thu Dec 24, 2009 11:41 pm

Done! 158
Upload your contribution to MFM drop box if you don't want others to take your contributed tracklogs or POIs.
http://www.malfreemaps.com/viewtopic.php?f=4&t=11630

User avatar
OngCC
Senior Mapper
Posts: 1434
Joined: Sun Sep 14, 2008 12:44 pm
Location: Redhill, SG
Contact:

Re: Singapore - Feedback (Q4 2009)

Postby OngCC » Thu Dec 24, 2009 11:43 pm

j4m35 wrote:Hi,

I just got my hands of a non-SG/MY Garmin 255W and am using Malfreemaps on it. Here's a few items I hope can be used to improve Malfreemaps. I am currently running on the '091221' maps.

1. The non-SG/MY Garmin 255W is able to speak out the road names and it seems to pronounce 'Yio Chu Kang Road' incorrectly. An example is, it says 'Turn Left on Y.I.O. Chu Kang Road'; as in it spells out Y I O instead of pronouncing it as one word Yio. It is able to pronounce 'Kio' properly (as in 'Ang Mo Kio') so I was wondering if anything could be done to make the Garmin 255W speak out 'Yio' properly.

2. In the 1st screenshot, routing shows a U-turn at the Holland Road / Holland Avenue juction N1 18.720 E103 47.760 that cannot be performed. Travelling westwards on Holland Road, you are only allowed to make a left turn into Holland Avenue or carry on westwards on Holland Road.

3. In the 2nd screenshot, I've put a waypoint on 177 Countryside Road (N1 23.230 E103 50.392). If I want to route to or from the west (e.g. to Upper Thomson Road), the Garmin will route via Lentor Drive (at the junction N1 23.041 E103 50.236) with a right turn onto Yio Chu Kang Road. As driving onto Lentor Drive involves climbing up a small hill and then descending from it, it is actually faster to route via Lentor Road then to turn right onto Yio Chu Kang Road (at the Lentor Road / Yio Chu Kang Road junction N1 23.165 E103 50.360). Is there anyway to update the map to make Yio Chu Kang Road prefered over Lentor Drive?

Best regards,
James

1. Not possible
2. Done
3. Tested in Mapsource, it route through Lentor Road
Upload your contribution to MFM drop box if you don't want others to take your contributed tracklogs or POIs.
http://www.malfreemaps.com/viewtopic.php?f=4&t=11630

j4m35
Posts: 20
Joined: Thu Dec 24, 2009 5:56 pm

Re: Singapore - Feedback (Q4 2009)

Postby j4m35 » Fri Dec 25, 2009 12:32 am

Hi OngCC,

I've attached the screenshot of the errorneous routing. I'm using Mapsource v6.15.7. The route I chose is 177 Countryside Road to Upper Thomson Road. As you see, Mapsource routes by Lentor Drive. And as I said in the previous message, Lentor Drive is a hill. So it would be better if it could route by Lentor Road.

Thanks for the help!

Best regards,
James

P.S. Merry Christmas!

My Mapsource route as what you think is better, i.e. Lentor road. :ko: - OngCC
You do not have the required permissions to view the files attached to this post.

User avatar
255w
Contributor
Posts: 217
Joined: Sat Nov 28, 2009 8:42 am
Location: Malaysia–Singapore

Re: Singapore - Feedback (Q4 2009)

Postby 255w » Fri Dec 25, 2009 9:13 pm

Routing error:
A) 354 Admiralty Drive
B) Sembawang Way
X) No right-turn (One-Way Street / Only Entry / No Exit)

Done! 158 - OngCC
You do not have the required permissions to view the files attached to this post.

j4m35
Posts: 20
Joined: Thu Dec 24, 2009 5:56 pm

Re: Singapore - Feedback (Q4 2009)

Postby j4m35 » Sat Dec 26, 2009 1:19 am

That's really interesting... Because my Garmin 255W (I selected 'Fastest time' as the routing preference) routes exactly how my Mapsource routes, as you've seen from the previous screenshot. :-?

Thanks for checking and listening to my grumbles anyway.

Cheers,
James

j4m35 wrote:Hi OngCC,

I've attached the screenshot of the errorneous routing. I'm using Mapsource v6.15.7. The route I chose is 177 Countryside Road to Upper Thomson Road. As you see, Mapsource routes by Lentor Drive. And as I said in the previous message, Lentor Drive is a hill. So it would be better if it could route by Lentor Road.

Thanks for the help!

Best regards,
James

P.S. Merry Christmas!

My Mapsource route as what you think is better, i.e. Lentor road. :ko: - OngCC

User avatar
255w
Contributor
Posts: 217
Joined: Sat Nov 28, 2009 8:42 am
Location: Malaysia–Singapore

Re: Singapore - Feedback (Q4 2009)

Postby 255w » Sat Dec 26, 2009 8:35 am

j4m35 wrote:That's really interesting... Because my Garmin 255W (I selected 'Fastest time' as the routing preference) routes exactly how my Mapsource routes, as you've seen from the previous screenshot. :-?

Thanks for checking and listening to my grumbles anyway.

Cheers,
James

Bro j4m35, it could be your setting. Please check your vehicle setting to see whether you are using Car/Motorcycle. I am able to reproduce your “problem” route if I change the vehicle to Bicycle or Pedestrian.

Via Lentor Drive
Bicycle
Pedestrian

via Lentor Drive.jpg

Via Lentor Road
Bus
Car/Motorcycle
Delivery
Emergency
Taxi
Truck
via Lentor Road.jpg
You do not have the required permissions to view the files attached to this post.

j4m35
Posts: 20
Joined: Thu Dec 24, 2009 5:56 pm

Re: Singapore - Feedback (Q4 2009)

Postby j4m35 » Sat Dec 26, 2009 10:39 am

Hi 255W,

Thanks for checking. It's really interesting because mapsource gives me this route via Lentor Drive with my vehicle setting set to Car/Motorcycle (which was the default since installing mapsource). I tried the other vehicle selections, but it still gives me the same route. ](*,)

However, if I select 'Shorter Distance' it routes me via Lentor Road. If I select 'Faster Time' it routes me via Lentor Drive. :-k

Cheers,
James

255w wrote:
j4m35 wrote:That's really interesting... Because my Garmin 255W (I selected 'Fastest time' as the routing preference) routes exactly how my Mapsource routes, as you've seen from the previous screenshot. :-?

Thanks for checking and listening to my grumbles anyway.

Cheers,
James

Bro j4m35, it could be your setting. Please check your vehicle setting to see whether you are using Car/Motorcycle. I am able to reproduce your “problem” route if I change the vehicle to Bicycle or Pedestrian.

Via Lentor Drive
Bicycle
Pedestrian

via Lentor Drive.jpg

Via Lentor Road
Bus
Car/Motorcycle
Delivery
Emergency
Taxi
Truck
via Lentor Road.jpg

User avatar
255w
Contributor
Posts: 217
Joined: Sat Nov 28, 2009 8:42 am
Location: Malaysia–Singapore

Re: Singapore - Feedback (Q4 2009)

Postby 255w » Sat Dec 26, 2009 11:44 am

j4m35 wrote:Hi 255W,

Thanks for checking. It's really interesting because mapsource gives me this route via Lentor Drive with my vehicle setting set to Car/Motorcycle (which was the default since installing mapsource). I tried the other vehicle selections, but it still gives me the same route. ](*,)

However, if I select 'Shorter Distance' it routes me via Lentor Road. If I select 'Faster Time' it routes me via Lentor Drive. :-k

Cheers,
James

Very strange indeed... For my case, both "Faster Time" and "Shorter Distance" gave me the same result, i.e. via "Lentor Road" for "Car/Motorcycle". Once I changed to "Pedestrian" mode, it will route via "Lentor Drive".
You do not have the required permissions to view the files attached to this post.

j4m35
Posts: 20
Joined: Thu Dec 24, 2009 5:56 pm

Re: Singapore - Feedback (Q4 2009)

Postby j4m35 » Sat Dec 26, 2009 12:12 pm

EDIT: I just installed MFM 091228, and now the routing routes via Lentor Road. Very weird...

And things are just getting weirder... As there are differences between the routing by your and OngCC's Mapsource and mine, I decided to test further. I tested similar routing (Countryside Road -> Upper Thomson Road) on my Garmin 255W (US Model) and my Garmin Mobile XT (running on a HTC Touch Cruise).

Both devices are giving me the results I see in my Mapsource. When set to 'Fastest Time', irregardless of my vehicle setting, the 255W and Mobile XT routes me via Lentor Drive. When set to 'Shortest Distance', 255W and Mobile XT routes me via Lentor Road.

Could it be the difference in Mapsource / Garmin set versions? Could it be possible that Garmin tweaked their routing algorithm with the newer versions leading to this result? My Garmin 255W is running on the latest firmware (checked from the webupdater), and I believe I'm running the latest version of Mobile XT.

And now, just for curiosity's sake, may I know your settings for the Driving Speeds? Mine were left as default as planned by Mapsource (see attached picture below).

Cheers,
James


255w wrote:
j4m35 wrote:Hi 255W,

Thanks for checking. It's really interesting because mapsource gives me this route via Lentor Drive with my vehicle setting set to Car/Motorcycle (which was the default since installing mapsource). I tried the other vehicle selections, but it still gives me the same route. ](*,)

However, if I select 'Shorter Distance' it routes me via Lentor Road. If I select 'Faster Time' it routes me via Lentor Drive. :-k

Cheers,
James

Very strange indeed... For my case, both "Faster Time" and "Shorter Distance" gave me the same result, i.e. via "Lentor Road" for "Car/Motorcycle". Once I changed to "Pedestrian" mode, it will route via "Lentor Drive".
You do not have the required permissions to view the files attached to this post.
Last edited by j4m35 on Mon Dec 28, 2009 5:30 pm, edited 1 time in total.

User avatar
255w
Contributor
Posts: 217
Joined: Sat Nov 28, 2009 8:42 am
Location: Malaysia–Singapore

Re: Singapore - Feedback (Q4 2009)

Postby 255w » Sat Dec 26, 2009 12:23 pm

j4m35 wrote:And now, just for curiosity's sake, may I know your settings for the Driving Speeds? Mine were left as default as planned by Mapsource (see attached picture below).


Bro, my speed setting is the same as yours.


Return to “SG Archives”

Who is online

Users browsing this forum: No registered users and 1 guest